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Introduction
This document explains how to set up a new project and how to extend an existing project using
Microsoft Visual C++ 6.0 and the FastObjects™ SDK.
Before you begin, verify that the Microsoft Visual C++ 6.0 and the FastObjects SDK are installed
and setup correctly. The simplest way to verify this is to open the project
"<FastObjectsDir>\Examples\cc\examples.dsw" with Microsoft Visual C++ 6.0 and then to
compile one of the examples. If there are no errors, then your installation is most likely correct.

General

Definitions

Definition Explanation

FastObjects
Developer

The FastObjects Developer is included in the distribution of theFastObjects
software. Using this tool you can manage FastObjects projects, set and
start pre-compiler runs, create and search within FastObjects databases.

Microsoft
Visual C++

This is the Microsofts Visual Studio C++ development environment
distributed by Microsoft.

ptxx The ptxx is the precompiler. Ít generates class factory files, among other
things, from the given hcd files. The class factory files provide the
extended runtime type information Poet needs to create and manage your
persistent objects. The Microsoft C++ compiler can then compile these
generated classes.

<FastObjectsDir> This is a placeholder for the path to your FastObjects installation directory.
Whenever <FastObjectsDir> is mentioned in this document, replace it with
the path to your FastObjects installation directory.
The default installation directories are "C:\Program Files\FastObjects_t7"
for FastObjects t7, "C:\Program Files\FastObjects_e7 for FastObjects e7
and "C:\Program Files\FastObjects_Trial" for the FastObjects Trial Edition
If you chose another directory during installation substitute
<FastObjectsDir> with your customized installation path.

References

Text Document

Additional
introductory
literature for
C++ developers

<FastObjectsDir>\doc\CppProgrammersGuide.chm

FastObjects C++
API Reference

<FastObjectsDir>\doc\CppReference.chm

Intended Audience

All users of FastObjects™ Trial Edition and all first time users of FastObjects™ e7/t7 software.
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Microsoft Visual C++ Settings
To make sure that Microsoft Visual C++ and the FastObjects SDK works together, you first have
to adjust some settings in the Microsoft Visual C++ IDE.

Directory Settings

Our example project will be created in the directory "C:\StepByStep". Please adjust your settings
according to your directory structure.
To ensure that the Microsoft Visual C++ Compiler can find all needed files you have to add some
directories to its "options". These settings needs to be adjusted only once, they will remain the
same for every Microsoft Visual C++ project you create from then on. You will find the settings
facility by clicking on "Tools ► Options... ► [Directories] ► Show directories for:" from the
Microsoft Visual C++ 6.0 main menu bar.

Executable Files

Choose "Show directories for: Executable Files" and add the following directories:
<FastObjectsDir>\bin
<FastObjectsDir>\runtime\bin\
(Substitute <FastObjectsDir> as described in the definitions table at the beginning of this
document).
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Include Files

Choose "Show directories for: Include Files" and add following the directory:
<FastObjectsDir>\inc
(Substitute <FastObjectsDir> as described in the definitions table at the beginning of this
document).

Library Files

Choose "Show directories for: Library Files" and add the following directory:
<FastObjectsDir>\lib
(Substitute <FastObjectsDir> as described in the definitions table at the beginning of this
document).
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Create a New C++ Project in Microsoft Visual C++

To create a new project in Microsoft Visual C++ choose
"File ► New ► [Projects] ► Win32 Console application".
Type in a project name (e.g. "StepByStep") and choose a location for storing the project (e.g. the
directory "C:\StepByStep ").
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Choose "An empty project" and click "Finish".

Click "OK" to create your project.



Step by Step - Poet FastObjects and Visual C++ 6.0

05/28/2002

Page 6

Settings for the New Project in Microsoft Visual C++

Adjust the project specific settings as follows (We will use Microsoft Visual C++ in release mode
with debug info enabled because we will use the release version of the FastObjects library
pt80.lib):

Click on Project ► Settings... ► [General] ► Microsoft Foundation Classes:" and choose
"Use MFC in a Shared DLL”
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Click on "Project ► Settings... ► [C/C++] ► Category: General ► Optimizations:” and choose
"Disable (Debug)”
Click on "Project ► Settings... ► [C/C++] ► Category: General ► Debug info:” and choose
"Program Database Edit and Continue”

Click on "Project ► Settings... ► [C/C++] ► Category: Code Generation ► Use run-time library:”
and choose "Multithreaded DLL”
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Additionally, you must set the include search path to the project directory by adding a ".".
To do this, click on "Project ► Settings... ► [C/C++] ► Category: Preprocessor
► Additional Include Directories:” and add the string "."
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You then have to specify the FastObjects library "pt80.lib".
To do this, click on "Project ► Settings... ► [Link] ► Category: General
► Object/library modules:” and type "pt80.lib"
To be able to debug the application, debug information needs to be generated.
To do this, click on "Project ► Settings... ► [Link]

► Category: General” and choose "�Generate debug info"
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FastObjects Settings
In addition to changing settings in Microsoft Visual C++ IDE, you have to do some FastObjects
specific changes as well.

Create an Alias for Your Object Database

You must ensure that your database can be found after it was created.
A FastObjects database consists of one or more object databases containing the data for the
persistent objects and one database containing the description of the persistent classes. The
latter database is called the "Dictionary". For further information about database and dictionary,
please refer to "FastObjects™ Programmer's Guide - C++":

You can access an object database with either of the two following methods:
� The absolute path name of the database can be specified directly in the source code, e.g. in

the following form: "C:\StepByStep\SBSBase\objects.dat". The disadvantage of this method is
that the database must reside at that fixed location all the times.

� The object database can be specified using an alias name, for example "StepByStepBase".
Then, using a configuration file, the alias name can be mapped to the physical location of the
object database. This method is more flexible as you do not have to recompile the sources
when the database location changes.

The object database finds its "Dictionary" using the same mechanism.
The safest technique is to define an alias name for both the object database and the dictionary.
Create the configuration file in the directory "C:\StepByStep”. For our example, the configuration
file "Poet.cfg” should have the following content (comment lines beginning with #can be omitted):
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Poet.cfg
#======================================================
# FastObjects configuration file
#======================================================

# Database for Step By Step Example
[databases\StepByStepBase]
name=C:\StepByStep\SBSBase

# Dictionary for Step By Step Example
[schemata\StepByStepDict]
name=C:\StepByStep\SBSDict
#======================================================

The FastObjects Schema Compiler, ptxx

Much of the power and simplicity of FastObjects comes from its ability to understand the structure
of your objects and the relationships expressed in your program through inheritance hierarchies,
pointers, and references.The ptxx schema compiler automatically extracts all needed information
from your persistent class declarations.

General

In general, the ptxx does the following:
� The ptxx schema compiler is invoked before the real compilation of C++ sources takes place
� The ptxx reads the specified C++ persistent class definitions and, if everything is correct,

creates the dictionary and the object database
� In addition, the ptxx also creates some C++ header and source files, which are called factory

files, that needs to be linked with the C++ application.
� New run of ptxx compilation is only necessary when member variables are changed in the

definitions of the persistent classes.

ptxx as a Tool in Microsoft Visual C++

For the sake of convenience, you must integrate ptxx as a tool to your development environment
so that ptxx gets invoked directly and automatically from Microsoft Visual C++.
Note: For demonstration purposes, we will integrate ptxx solely in a very simple way in our
example. In a "real" project ptxx will be integrated in a more differentiated way, for example, to
compile only files that were changed. More information can be found in the "FastObjects™
Programmer's Guide - C++":
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To integrate ptxx, the following changes needs to be done in Microsoft Visual C++ IDE:

Click on "Tools ► Customize... ► [Tools] ► Menu contents:” and specify
"Fast&Objects Precompiler".
Click on "Tools ► Customize... ► [Tools] ► Command:” and specify "ptxx.exe".
Click on "Tools ► Customize... ► [Tools] ► Arguments:” and specify
"-v -xi -I<FastObjectsDir>\inc -d StepByStepBase -xc StepByStepDict Person.hcd".
(Substitute <FastObjectsDir> as described in the definitions table at the beginning of this
document. For an explanation of what "Person.hcd" is, please refer to the next section).
Click on "Tools ► Customize... ► [Tools] ► Initial directory:” and specify "$(ProjDir)".
Click and check the option "Tools ► Customize... ► [Tools] ► Use Output Window”.
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Code your Program
Now everything is prepared to begin the "real" work of coding your program. We will illustrate the
next steps using an example.
Using a simple class called "Person”, we will explain the general procedure for creating a
complete new program. We define a class "Person" with the persons' name as a member and
four methods: SetName() to set a persons' name, GetName() to retrieve a persons' name, Show()
to display a persons' name on screen and Fill() to read in a persons' name from screen:

At this point of time we need not care about the quality of the class design here. To keep this
tutorial short, we will only show one of many possible ways.

Define Persistent Classes

In principle, there are two ways of specifying persistent class definitions: It is possible to define all
persistent classes in one single file or to define each class in a separate file. In this tutorial, we
will write all class definitions into one header file and all class implementations into one source
file.
Persistent classes will be defined in a header file with a file extension ".hcd". The syntax is the
same syntax as for the C++ programming language with additional FastObjects keywords. These
hcd files can be added to a folder in your project directory in the Microsoft C++ Visual Studio. The
implementations of the class’s methods will be provided in the corresponding ".cpp" files.

Create the Files

Three files must be created for our example: Person.hcd, Person.cpp and main.cpp.
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For each new file choose "File ► New ► [Files] ► C++ Source File" and type in the file name
(e.g. "Person"). For "Person.hcd" you must enter the full name including the extension.

Following is the content of the three files:
Person.hcd
// ----------------------------------------------------------------
#ifndef INC_PERSON_H
#define INC_PERSON_H

#include <poet.hxx>
#include <ptstring.hxx>
// ----------------------------------------------------------------
persistent class Person
{
private:
PtString m_sName;
public:
Person();
Person(PtString & sName);
virtual ~Person();

void SetName(PtString & sName);
PtString GetName();
virtual void Show();
virtual void Fill();
};
// ----------------------------------------------------------------
#endif
// ----------------------------------------------------------------
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Person.cpp
// ----------------------------------------------------------------
#include <iostream.h>
// ----------------------------------------------------------------
// cxx-Files generated by ptxx
#include "Person.cxx"
// ----------------------------------------------------------------
Person::Person()
: m_sName("")
{
}
// ----------------------------------------------------------------
Person::Person(PtString & sName)
{
this->m_sName = sName;
}
// ----------------------------------------------------------------
Person::~Person()
{
}
// ----------------------------------------------------------------
void Person::SetName(PtString & sName)
{
this->m_sName = sName;
}
// ----------------------------------------------------------------
PtString Person::GetName()
{
return m_sName;
}
// ----------------------------------------------------------------
void Person::Show()
{
cout << "Name:" << (char*) m_sName;
}
// ----------------------------------------------------------------
void Person::Fill()
{
char buf[128];

cout << "Name:";
cin >> buf;
cout << endl;
m_sName = buf;
}
// ----------------------------------------------------------------
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main.cpp
// ----------------------------------------------------------------
#include <iostream.h>
#include <stdlib.h>
#include <ctype.h>
#include "Person.hxx"
//----------------------------------------------------------
void ShowAllPerson(PtBase * pBase)
{
PersonAllSet * pAllPerson = new PersonAllSet(pBase);
Person * pPerson = 0;

cout << "----------------------" << endl;
cout << "Person in Base:" << endl;
cout << "----------------------" << endl;
if (pAllPerson->Get(pPerson, 0, PtSTART) == 0)
{

do
{

pPerson->Show();
cout << endl;
pAllPerson->Unget(pPerson); // forget person

} while (pAllPerson->Get(pPerson, 1, PtCURRENT) == 0);
}
delete pAllPerson;
cout << "----------------------" << endl;
}
//----------------------------------------------------------
int CreatePerson(PtBase * pBase)
{
int iError = 0;
// new person
Person * pPerson = new Person();

pPerson->Fill();
iError = pPerson->Assign(pBase);
if (!iError) iError = pPerson->Store();
pPerson->Forget();
if (iError)
{

cout << "Error: " << iError << endl;
}
return iError;
}
//----------------------------------------------------------
int main (void)
{
int iError = 0;
PtBase * pBase = 0;
char buffer[120];

InitPOET(PtTransactionByBase);
iError = PtBase::POET()->GetBase("LOCAL", "StepByStepBase", pBase);
if (iError < 0)
{

PtBase::POET()->UngetBase(pBase);
cout << "Open-Error: " << iError << endl;
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return iError;
}
else
{

int noExit = 1;

for (; noExit;)
{

cout << "(A)ll Person" << endl;
cout << "(P)erson create" << endl;
cout << "(E)nd" << endl;
cin >> buffer;
switch (toupper(buffer[0]))
{

case 'A':
ShowAllPerson(pBase);

break;
case 'P':
{

iError = CreatePerson(pBase);
if (iError)
{

noExit = 0;
}

}
break;
case 'E':

noExit = 0;
break;
default:

cout << "Unknown Command!" << endl;
break;

} // End switch (toupper(buffer[0]))
}
// close base
PtBase::POET()->UngetBase(pBase);

}
DeinitPOET();
return iError;
}
// ----------------------------------------------------------------
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Add the Files to Your Microsoft Visual C++ Project

All files must be added to the Microsoft Visual C++ 6.0 project. If you have created the files as
described in the previous section, the files are added automatically to the project. If you have
created the files other than described above you have to add the files manually.
To do so, first, store these files in your project directory (in our example: "C:\StepByStep"). Then,
activate the context menu with a click on the right mouse button. Using the menu entry, "Insert
File into Project", you can add the three files to the project.
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Start the ptxx

Now, before we can let Microsoft Visual C++ compiler compile the files in the project, we have to
invoke the schema compiler ptxx to generate the database, dictionary and the factory files.

To start the FastObjects schema compiler click on: "Tools ► FastObjects Precompiler"
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The output from ptxx should look like this:
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In your project directory, verify that all needed files were generated. The project directory should
look something similar to this:

Compile and Test the Program

Compile

Now, we can compile our project with Microsoft Visual C++ by pressing key F7, which produces
an executable application. If there were no errors, we then can run the program by pressing F5
key.
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Test

To test the program, add some persons by providing appropriate choices and data when
prompted by the test program. You can view (and edit) the contents of your object database using
the "FastObjects Developer".
To do so, start the "FastObjects Developer".
To open your object database in the "FastObjects Developer" click on
"File ► Open Database... ► [Open FastObjects Database]".
Specify "Host" as LOCAL and "Database" as StepByStepBase.

To see the class structure click on "Classes ► Browse Classes”
(For the FastObjects Trial Edition this menu entry is called "Classes ► Browse”)
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You can view and manipulate the content of the object data in the object database by clicking on
"Objects ► Browse Objects”
(For the FastObjects Trial Edition this menu entry is called "Objects ► Browse Extent”)
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Extending an Existing Program
As a second example, we will now explain how to extend an existing program by extending our
Person program with the "Customer" class.
We will derive a class called "Customer" from the "Person” class. The "Customer" class will have
the customer’s number as a member and four methods: SetCustomerNo(), to set a customers'
number, GetCustomerNo(), to retrieve a customers' number, Show(), to display a customers'
number on the screen and Fill(), to read in a customers' number from the screen.

Add a Derived Persistent Class

Edit your Person.hcd file to include the following lines:
...
// ----------------------------------------------------------------
persistent class Customer : public Person
{
private:
int m_iCustomerNo;
public:
Customer();
Customer(PtString & sName);
Customer(PtString & sName, int iCustNo);
virtual ~Customer();

void SetCustomerNo(int iCustNo);
int GetCustomerNo();
virtual void Show();
virtual void Fill();
};
// ----------------------------------------------------------------
#endif
// ----------------------------------------------------------------
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and extend your Person.cpp with the following lines:
// ----------------------------------------------------------------
...
// ----------------------------------------------------------------
Customer::Customer()
:m_iCustomerNo(0)
{
}
// ----------------------------------------------------------------
Customer::Customer(PtString & sName)
: Person(sName), m_iCustomerNo(0)
{
}
// ----------------------------------------------------------------
Customer::Customer(PtString & sName, int iCustNo)
:Person(sName), m_iCustomerNo(iCustNo)
{
}
// ----------------------------------------------------------------
Customer::~Customer()
{
}
// ----------------------------------------------------------------
void Customer::SetCustomerNo(int iCustNo)
{
this->m_iCustomerNo = iCustNo;
}
// ----------------------------------------------------------------
int Customer::GetCustomerNo()
{
return m_iCustomerNo;
}
// ----------------------------------------------------------------
void Customer::Show()
{
Person::Show();
cout << ", CustomerNo:" << m_iCustomerNo;
}
// ----------------------------------------------------------------
void Customer::Fill()
{
Person::Fill();
cout << "CustomerNo:";
cin >> m_iCustomerNo;
cout << endl;
}
// ----------------------------------------------------------------
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Change Invocation of ptxx

To precomile the extended program we must change some settings for the ptxx.
Change the following in Microsoft Visual C++ IDE:

Click on "Tools ► Customize... ► [Tools] ► Arguments:"
Change the entry "-xc" to "-xu" (this means the existing dictionary will be updated)
"-v -xi - I<FastObjectsDir>\inc -d StepByStepBase -xu StepByStepDict Person.hcd"
(Substitute <FastObjectsDir> as described in the definitions table at the beginning of this
document).

New Start of ptxx

Close the object database in the FastObjects Developer before you restart the FastObjects
schema compiler; else you will get an error message. If FastObjects Developer is running when
you run the ptxx schema compiler, all the verbose output from the ptxx schema compiler is sent to
the Messages Window of the FastObjects Developer. You can see the messages there. However,
if FastObject Developer was not running when you run ptxx compiler, then all the verbose output
from the ptxx compiler will be redirected to Microsoft Visual C++ IDE as before.
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Extend, Compile, and Test main.cpp

Edit main.cpp to include the following lines:
//----------------------------------------------------------
#include <iostream.h>
#include <stdlib.h>
#include <ctype.h>
#include "Person.hxx"
//----------------------------------------------------------
void ShowAllCustomer(PtBase * pBase)
{
CustomerAllSet * pAllCustomer = new CustomerAllSet(pBase);
Customer * pCustomer = 0;

cout << "----------------------" << endl;
cout << "Customer in Base:" << endl;
cout << "----------------------" << endl;
if (pAllCustomer->Get(pCustomer, 0, PtSTART) == 0)
{

do
{

pCustomer->Show();
cout << endl;
pAllCustomer->Unget(pCustomer);

} while (pAllCustomer->Get(pCustomer, 1, PtCURRENT) == 0);
}
delete pAllCustomer;
cout << "----------------------" << endl;
}
//----------------------------------------------------------
void ShowAllPerson(PtBase * pBase)
{
PersonAllSet * pAllPerson = new PersonAllSet(pBase);
Person * pPerson = 0;

cout << "----------------------" << endl;
cout << "Person in Base:" << endl;
cout << "----------------------" << endl;
if (pAllPerson->Get(pPerson, 0, PtSTART) == 0)
{

do
{

pPerson->Show();
cout << endl;
pAllPerson->Unget(pPerson); // forget person

} while (pAllPerson->Get(pPerson, 1, PtCURRENT) == 0);
}
delete pAllPerson;
cout << "----------------------" << endl;
}
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//----------------------------------------------------------
int CreateCustomer(PtBase * pBase)
{
int iError = 0;
Customer * pCustomer = new Customer();

pCustomer->Fill();
iError = pCustomer->Assign(pBase);
if (!iError) iError = pCustomer->Store();
pCustomer->Forget();
if (iError)
{

cout << "Error: " << iError << endl;
}
return iError;
}
//----------------------------------------------------------
int CreatePerson(PtBase * pBase)
{
int iError = 0;
// new person
Person * pPerson = new Person();

pPerson->Fill();
iError = pPerson->Assign(pBase);
if (!iError) iError = pPerson->Store();
pPerson->Forget();
if (iError)
{

cout << "Error: " << iError << endl;
}
return iError;
}
//----------------------------------------------------------
int main (void)
{
int iError = 0;
PtBase * pBase = 0;
char buffer[120];

InitPOET(PtTransactionByBase);
iError = PtBase::POET()->GetBase("LOCAL", "StepByStepBase", pBase);
if (iError < 0)
{

PtBase::POET()->UngetBase(pBase);
cout << "Open-Error: " << iError << endl;
return iError;

}
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else
{

int noExit = 1;

for (; noExit;)
{

cout << "(A)ll Person" << endl;
cout << "(S)how Customer" << endl;
cout << "(P)erson create" << endl;
cout << "(C)ustomer create" << endl;
cout << "(E)nd" << endl;
cin >> buffer;
switch (toupper(buffer[0]))
{

case 'A':
ShowAllPerson(pBase);

break;
case 'P':
{

iError = CreatePerson(pBase);
if (iError)
{

noExit = 0;
}

}
break;
case 'S':

ShowAllCustomer(pBase);
break;
case 'C':
{

iError = CreateCustomer(pBase);
if (iError)
{

noExit = 0;
}

}
break;
case 'E':

noExit = 0;
break;
default:

cout << "Unknown´Command!" << endl;
break;

} // End switch (toupper(buffer[0]))
}
// close base
PtBase::POET()->UngetBase(pBase);

}
DeinitPOET();
return iError;
}
//----------------------------------------------------------

You can now compile and test your extended program the same way you compiled and tested the
first program.
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Conclusion
You have now generated an executable application with persistence-enabled classes and a
FastObjects database that can store them. Your project is now completely installed and you can
work with the FastObjects database.
To find out what more you can do with FastObjects, please study the examples that are
distributed with the product carefully. Also, it is highly advisable to refer to the "FastObjects
Programmer’s Guide - C++", and the "FastObjects Reference - C++” that are distributed with the
FastObjects SDK. You have now completed the first step toward a successful project!
Have Fun!
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