
Creating Bootable CD’s and floppies has become an important 
knowledge for every PC/NT engineer! 
 
Howto create powerful boot floppies your find here: 
   

http://www.nu2.nu/bootdisk/ 
 

http://www.nu2.nu/bootdisk/modboot/ 
 
You can build floppies with almost ANY driver, most CD/DVD-ROM support and many network interface 
drivers. 
 
Create a custom bootable CD-ROM 
 
Create your own custom-made bootable CD-ROM with virus recovery and back-up restoration 
options.  
So far in the Windows Hidden Secrets series, we've covered aspects of the operating system itself, from 
working with security policies to slimming down your Windows directory. This month we're taking a 
different approach, since we've covering the subject of bootable CD-ROMs - what they are, how to 
create them and why they can save your life in the event of a virus attack. 
 
PC architecture has changed a lot over the last couple of years. Previously, you could boot your PC 
from either the internal hard drive or a bootable floppy disk - and that was it. The changes to the PC's 
BIOS - the small program held on a chip on your motherboard that kickstarts the PC and loads the 
operating system - mean that your PC can now boot directly from an IDE CD-ROM drive. If you have a 
full installation of Windows 98, you have a bootable CD in your possession already. 
 
You can boot directly from this CD, and you're given the option of continuing the boot process from CD - 
which runs the Windows 98 installation program - or booting directly from your hard drive if an operating 
system is present. 
 
Created Equal? 
Not all CD volumes are created using the same methods though, and you can't just boot from any old 
disc. Normal CD-ROMs are created using the ISO9660 file system, and are readable on any PC running 
MS-DOS, Windows or Linux. Bootable CD volumes use a standard known as El Torito, created by 
Phoenix Technologies. This standard has been rapidly adopted over the last couple of years, despite 
sounding like a famous brand of tortilla chips, and all modern motherboards support booting your PC 
from El Torito CD-ROMs. 
 
There are numerous reasons why it's worth the bother of creating a bootable CD for yourself. First, 
there's the problem of viruses. Many viruses can stop Windows dead before it's even loaded. Nasty 
pieces of work such as Win32.MTX can cause absolute havoc by bringing your Windows installation to a 
grinding halt, making it hard to get going again without a complete partition wipe and re-installation of 
Windows. Some anti-virus suites can run directly from MS-DOS without Windows being loaded, making 
them a useful recovery tool. With a custom-made bootable CD that loads MS-DOS directly from a CD-R, 
you can run a virus checker, such as Norton AntiVirus 2001, directly from DOS, disinfecting your 
Windows installation with very little hassle. 
 
All very well if you're foresighted enough to create the virus-killing bootable CD before disaster strikes, 
but what about when you find you have no other choice but to re-install Windows? Once that arduous 
task is done, you can future-proof yourself to make it very easy to recover from a similar situation again. 
Once you've installed Windows and you have it set up the way you want it along with all of the device 
drivers installed for your hardware, you can use an imaging tool such as Symantec's Norton Ghost or 
PowerQuest's DriveImage to create an image of your hard drive to restore your system in the event of 
disaster. 
 
 
 
 
 
 
We've discussed disk images in PC Answers many times before now. Basically, an image is a 
compressed file containing every bit of information on your hard drive - files, folders and all data needed 
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to recreate the hard-disk partition exactly as it was when you created the image. With a few mouse 
clicks, you can restore a crippled PC back to your own custom equivalent of the default factory settings 
offered by major PC manufacturers. 
 
Create a custom bootable CD-ROM 
 
What Do I Need? 
The most obvious requirement here is that you need to own a CD-Recordable drive. It doesn't matter 
whether it's a SCSI or an IDE drive, and it makes no difference if it's an older drive that doesn't support 
CD-RWs either, since you'll be using a CD-R to create your bootable volume. 
 
You'll also need some CD-mastering software that's capable of creating bootable discs that conform to 
the El Torito specifications. For the purposes of this month's Hidden Secrets we're using Ahead's Nero 
Burning ROM 5 since it both makes the creation process easy and comes available in a free 30-day 
evaluation that you can download and use to create your one-off bootable CD-ROM. You can download 
the demo version of Nero from www.ahead.de. If you already have some mastering software that came 
with your drive, then you may be able to use it to follow this tutorial. Other than Nero, the most popular 
bundled software with new CD-R drives is Roxio's nifty Easy CD Creator, which can also create El 
Torito volumes, though you'll have to check the manual for information on how to do this. 
Finally, you'll need a blank CD-R or two. You should only need the one, but make sure you have a 
couple of spares handy in case of mistakes on your part or because of errors such as buffer underruns. 
You'll also need a blank floppy disk - more on why you need this later.  
 
Altered Images 
As we said earlier, bootable CD-ROM volumes differ from normal data CDs in that they use a 
specialised file system that's created for the purpose. The area of the CD that actually handles the boot 
process needs to contain what's known as a boot image. Put simply, your bootable CD-ROM requires 
the image of another existing bootable volume to work. What happens is that the BIOS temporarily 
assigns your CD-ROM drive the drive letter A, and re-allocates your floppy drive to B. The PC boots up 
as normal from the boot image placed on your bootable CD as if it were a real floppy drive. 
 
The easiest way to capture a boot image is from a floppy disk you know already boots your system, 
such as a Windows start-up disk - run Add/Remove Programs from the Control Panel, iclick on Startup 
Disk tab and then the Create Disk button, making sure a floppy is in the drive. 
 
If you plan to use Norton Ghost to archive your existing system state to CD for later retrieval, it's worth 
noting that you can also use the Ghost Boot Wizard to create a boot floppy with CD-ROM support, which 
will do much the same job, and saves your having to copy the Ghosted files to your CD-ROM later on.  
 
And if your PC has SCSI drives, you'll also need to make sure you copy the correct DOS drivers for your 
SCSI card to the boot floppy before you proceed, or your bootable CD won't be able to access any SCSI 
drives on your system. 
 
Creating a custom bootable CD with Nero 
1 - Insert your start-up disk into your floppy drive and launch Nero. When the New Compilation Wizard 
opens, scroll down and select the icon labelled CD-ROM (Boot). Switch to the Boot tab and ensure that 
the source of the image data is set to drive A.  
 
2 - Switch to the ISO tab. To make sure the disc is perfectly readable under MS-DOS,set the buttons to 
ISO Level 1, ISO 9660 character set and clear the two boxes in the Relax ISO Restrictions section. 
 
3 - Switch to the Label tab and make sure the drop-down menu at the top is set to ISO9660 and not 
Joliet. Give your CD meaningful name such as 'BOOT' or something similar.Click the New button to 
close the Wizard and open Nero itself. 
 
4 - Use the File Browser window to navigate to directories containing any program files you want to copy 
to the CD, such as your copy of Norton AntiVirus or Ghost. Drag the directories and drop them on top of 
the CD icon in the left-hand window to add them to the CD.  
 
5 - Click the Write icon on the Nero toolbar, or select Write CD from the File menu to open this dialog. 
Switch off Determine maximum speed and Simulation, then click the Write button to begin.  
 
6 - Once it's finished,restart your PC with the CD in your drive and your custom boot CD will load, 
leaving you at the DOS prompt. To test Norton AntiVirus, change to the directory on CD and type 
NAVDX to see full list of commands.NAVDX /A will scan all drives except floppies, for example. 
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How to Make Bootable CDs 
Creating a CD-ROM that is bootable is easier than you think! Matt Jones 

explains how, in this practical guide from PC Support Advisor.  
 
This is a plain html version of the original article. For the original version in PDF format 
complete with pictures, click here.   

 
There are many applications for bootable CD-ROMs (we'll call them BCDs) - 
the most common being when undertaking large roll-outs and when using test 
rigs, where it is often useful to combine operating systems with boot and 
diagnostic diskettes to automate the process of setting up machines.  
If you need to repeatedly test from clean installations it can save lots of time if 
you image a disk drive and put the image, along with the imaging software, on 
a BCD.  
 
It can also be a timesaver to have frequently used boot and diagnostic 
diskettes on CD, and it's an easy way to work with PCs that do not have a 
floppy disk drive.  
 
To see if a PC supports booting from a CD, check your BIOS set-up screens. 
SCSI drives have their own BIOS on the adapter; IDE drives use code in the 
system BIOS. Most modern SCSI adapters have a BIOS that allows it, and 
most motherboards of the last two years support booting from IDE CD drives.  
 
If you are able to change the boot options, and it lists "CD-ROM", your system 
supports booting from a CD. If you have a 1995 or 1996 motherboard or SCSI 
card that does not support it, it's probably worth contacting the manufacturer -
many have BIOS upgrades available.  
 
Technical Details  
When a BCD is created, a "boot record" is put at the very beginning of the 
CD, just as it is with a bootable floppy or hard disk.  
 
This record specifies whether the CD is to emulate a floppy or hard disk drive, 
and contains a pointer to the location of the actual boot image file.  
 
The El Torito specification, created by IBM and Phoenix Technologies, was 
designed to be completely compatible with the ISO 9660 CD standard. It adds 
to the ISO 9660 specification by requiring a boot record at sector 11 of the last 
session on the CD.  
 
The boot record contains an absolute sector number that points to the "boot 
catalog". There's no restriction on the location of the boot catalog. The catalog 
contains a list of entries describing all the "boot images" present on the CD.  
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Again, there's no restriction on where the boot images can be on the CD.  
 
There can be any number of them, of three different types:  

•  "Bootable emulation" causes the image to be mapped to drive A or C, 
as a conventional bootable storage device.  

•  "Non-bootable emulation" maps the image as a conventional storage 
device, and allocates the last drive letter to it.  

•  "No emulation" is a special mode which loads the image into memory 
and executes it -extremely useful when developing copy protection or 
"smart" CDs designed for a variety of disparate systems. For example, 
the "no emulation" mode is used in the Windows NT operating system 
CDs.  

 
There is much scope for system vendors to create multi-image CDs where the 
boot image is selected dynamically by the system BIOS, but this requires a lot 
of manual assembling and editing, and is beyond the range of this article.  
 
Although it is relatively easy to manually assemble the boot catalog, most 
BIOSes do not allow selection of the image and you will have to write a small 
amount of low level system code to do it. CDs can be set to boot as drive A or 
C. The fact that they are a late addition to the PC makes them subject to 
certain other restrictions.  
 
To boot as drive A, the boot image must be made in the same format as a 1.2 
MB, 1. 4 MB or 2. 88 MB floppy disk. The first floppy disk drive, if present, will 
become the B drive. If the system has a second floppy disk drive, it will not be 
accessible.  
 
If the CD is set to boot as the C drive, it replaces the normal hard disk drive C, 
and has no size limit other than that of the CD itself. However, the source 
drive image must have only one partition. This partition must be both the first 
entry in the partition table and a standard DOS partition.  
 
Creating The Image  
Most current CDR publishing packages are capable of reading a floppy disk 
and creating a boot image from it. With the appropriate menu choices made, 
they will automatically "inject" it into the CD image.  
 
With this method it is extremely easy to make a bootable CD. Some of the 
more advanced packages like Nero can create a bootable CD from any disk 
image, and allow fine-tuning of parameters such as the emulation type and 
start-up message. The basic process for making a bootable CD from a floppy 
disk is as follows:  

1. Create a bootable floppy disk that has all required driver and start-up 
software on it. You will need a CD driver in order to use the CD in a 
conventional manner once the system has finished booting. It is wise to 
use a generic CD driver if you plan on using it in a few different 
systems.  

2. Make sure that any path names in the config.sys and autoexec. bat 
files do not specify drive letters.  
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3. Make sure your boot process does not attempt to write to the disk. Set 
the read-only flag on all files and write-protect the disk if possible. If 
your system tries to write to the CD on boot-up, it will crash.  

4. Test this disk thoroughly in whatever PC environments you wish to use 
it.  

5. Once you are happy with the bootable disk, create the CD with your 
CDR publishing package. Selecting the "bootable" option will usually 
prompt for the floppy disk. Put any other data onto the CD in the same 
session.  

 
Larger Images  
If you wish to create a larger, hard disk type image, there are a few more 
things to do.  
 
You will need to choose and size your source image hard disk carefully. A 
program such as PowerQuest's Partition Magic is very handy for tasks like 
this.  
 
Create and test your image in the same manner as the floppy image 
procedure detailed above. When you are happy with it, use a program like  
 
Norton's DiskEdit or PowerQuest's Drive Image to read the drive and create 
an image of it in a single file.  
 
At this point, if your CDR publishing software supports disk file images, you 
can simply select the appropriate file and it will automatically create the 
correct boot records.  
 
If your software does not support hard disk images, it is still possible to create 
them if you are willing to delve into image files and boot records with a hex 
editor. This is not as difficult as it sounds, and Phoenix Technologies have an 
excellent guide on how to do it on their Web site at www. ptltd. com.  
 
It should be noted, however, that in most cases the floppy disk image method 
is sufficient because drivers can be loaded that allow the rest of the CD to be 
mounted in the DOS session.  
 
 Tips  
* A rewriteable CDR drive is an extremely useful tool when experimenting with 
bootable CDs. Although your test CD-RW may be unusable in some standard 
CD drives, it can be used on the mastering system if the CD-RW drive is set 
as the primary CD, and this is enough for general test purposes.  
 
* If you are planning on making a variety of bootable CDs, or just 
experimenting, CD-RW has the obvious advantage of media cost. If you don't 
have a CD-RW, any failed experiments can be used as multi-session 
backups.  
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* When making hard disk image CDs, an old hard disk drive around 650 MB in 
size makes a useful addition to your mastering system. As hard disk images 
have certain partitioning requirements, detailed above, it's much easier to 
have a whole disk to use for your layout if you are doing this type of work.  
 
* Under Windows NT, you will need to have administrative rights if you are 
creating hard disk images (this requires access to all disk sectors).  
 
* It is possible that you will encounter older CDs that start to boot, fail 
immediately and hang your system. This is because there was no initial 
standard for the first few sectors of CDs and, although unlikely, some may 
contain a correct "validation entry" without any of the other required boot files.  
 
CDR Software  
Until fairly recently, bootable CDs had to be made manually with a 
combination of low level tools.  
 
 Utility programs such as BOOTISO and DISKIMG were used to read 
bootable disks and write images to disk files. These disk images were then 
hex edited and manually added to the CD layout.  
 
It has now become much easier, with many current CDR writer software 
packages able to make bootable CDs from a floppy disk image, a hard disk or 
an image file. Notable software packages are Easy CD Creator, WinOnCD, 
CDRWIN, HyCD and Nero.  
 
The latter is an extremely powerful tool that offers complete control of the CD 
writing process, and can create bootable CDs for many platforms. It can also 
create "oversized" CDs which can be used to gain a small amount of copy 
protection.  
 
Many of these programs can be evaluated before purchase, and this is 
advisable due to the wide variation in CDR drivers and hardware. 
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Manually creating a boot floppy disk with real-mode DOS CD-ROM 
driver support. 
 
The following outlines creating a bootable startup disk with real-mode CD-ROM 
support, a "must have" item when performing various repair work.  
 
Creating a DOS boot disk 
 
(A) Via a command prompt in DOS  

1. Insert a blank 3.5" floppy disk  
2. Click Start > Point to Programs > Click the MS-DOS Prompt  
3. Type FORMAT A: /S and tap [ENTER]  
4. When prompted for a Volume Label tap [ENTER]  
5. When prompted "Format another?" type N and tap [ENTER]  
6. Type EXIT and tap [ENTER]  

(B) Via Windows Explorer in Win95/98/ME/XP/2000/2003 

1. Insert a blank 3.5" floppy disk  
2. Click Start > Point to Programs > Click Windows Explorer  
3. Right-Click on the icon for 3½ Floppy [A:] > Click Format...  
4. Choose the option "Copy system files only" > Click Start  
5. When the process completes Click Close  

Adding Real-Mode CD-ROM Support 
 
Four files must be added to your boot disk in order for the CD-ROM drive to be 
accessable in DOS when booting with the disk:  

1. A real-mode CD-ROM driver  
2. Microsoft's MSCDEX TSR program  
3. A CONFIG.SYS file with a line loading the CD-ROM driver  
4. An AUTOEXEC.BAT file with a line loading the MSCDEX TSR  

1- Adding a Real-Mode CD-ROM Driver 
 
By default IBM installs a real mode CD-ROM driver for use in DOS to 
the C:\Windows\Command folder. On older Aptivas this file is named 
IBMIDECD.SYS, on newer systems the file is VIDE-CDD.SYS. 
 
In order to add CD-ROM support to a boot disk a copy of one of the above files 
must be added to the disk. This can be achieved via standard Windows procedures 
such as Copy > Paste, Drag > Drop, SendTo > A:\ and so forth, or via the following 
commands issued from a command prompt in DOS: 
 
On older Aptivas with the IBMIDECD.SYS driver:
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Type COPY C:\WINDOWS\COMMAND\IBMIDECD.SYS A:\ 
and tap [ENTER] 
 
On newer Aptivas with the VIDE-CDD.SYS driver: 
 
Type COPY C:\WINDOWS\COMMAND\VIDE-CDD.SYS A:\ 
and tap [ENTER] 
 
If Windows procedures are used note that often by default files with 
the *.SYS extension will be HIDDEN, make sure that the system is 
set to Show all files:  

• Open Windows Explorer  
• Click View > Click Options  
• Choose "Show all files" > Click OK  

2- Adding the MSCDEX CD-ROM TSR 
 
To load CD-ROM support and optionally assign the CD-ROM to a particular drive 
letter the Microsoft program MSCDEX.EXE must be added to the disk. This file is 
also found in C:\Windows\Command by default and copying it to disk can be 
achieved via standard Windows procedures such as Copy > Paste or SendTo > A:\ 
or via the following command issued from a command prompt in DOS: 
 
Type COPY C:\WINDOWS\COMMAND\MSCDEX.EXE A:\ 
and tap [ENTER] 
 
3- Adding a CONFIG.SYS to Load the Real-Mode CD-ROM Driver 
 
A CONFIG.SYS file must be added to the disk containing a line to load the real-
mode CD-ROM driver into memory when the PC is booted using the disk.  

1. Open the Windows NotePad program  
2. Type one of the following lines: 

 
On older Aptivas with the IBMIDECD.SYS driver: 
DEVICEHIGH=A:\IBMIDECD.SYS  /D:IBMCD001 
 
On newer Aptivas with the VIDE-CDD.SYS driver: 
DEVICEHIGH=A:\VIDE-CDD.SYS  /D:IBMCD001 

3. Click File > Click Save As  
4. Under Save in pull down the menu and choose Drive A  
5. In the Named box type "config.sys" (include the quotes)  
6. Click the Save button  

Note that if preferred (or if one doesn't have access to Windows while creating the 
boot disk) as an alternative the files discussed in steps (3) and (4) can also be 
created in native DOS using the DOS text editor EDIT.COM. To do so:
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From a command prompt type EDIT and tap [ENTER] to launch the DOS text editor 
> Type the appropriate text > Press ALT+F to bring down the File menu > Use the 
down arrow key to highlight Save > Tap [ENTER] > After "file name" type the name 
of the file you are creating as either A:\CONFIG.SYS or A:\AUTOEXEC.BAT > Tap 
[ENTER] > Press ALT+F again > Use the down arrow key to highlight Exit > Tap 
[ENTER] 
 
4- Adding an AUTOEXEC.BAT to Load the MSCDEX TSR 
 
An AUTOEXEC.BAT file must be added to the disk containing a line to load the real-
mode CD-ROM TSR MSCDEX into memory and optionally setting the CD-ROM 
drive letter assignment when the PC is booted using the disk.  

1. Open the Windows NotePad program  
2. Type the following line: 

 
LH A:\MSCDEX.EXE /D:IBMCD001 /L:x 
 
Note: x above = your CD-ROM drive letter  

3. Click File > Click Save As  
4. Under Save in pull down the menu and choose Drive A  
5. In the Named box type "autoexec.bat" (include the quotes)  
6. Click the Save button  

Note that the CD-ROM can be assigned to any drive letter you wish, however that 
letter MUST come after all hard drive letter assignments. One can optionally omit 
the /L:x switch, in which case the CD-ROM 
will automatically be assigned to the first open drive letter after all 
hard drive partitions are assigned. 
 
Adding Optional Command Line Utilities 
 
One can add a wide variety of MS-DOS command line utilities to a 
boot disk to make it a more useful tool. Strictly for the purposes of performing a 
clean install of Windows 98 at the bare minimum I would strongly suggest adding 
the FORMAT.COM and FDISK.EXE utilities, and if one plans to install Win98 from 
their hard drive rather than CD 
add XCOPY.EXE as well. 
 
Again all of these items can be found in C:\Windows\Command by default and they 
can be copied to the boot disk via standard Windows procedures such as Copy > 
Paste or SendTo > A:\ or via the following commands issued from a command 
prompt in DOS:  

• COPY  C:\WINDOWS\COMMAND\FORMAT.COM  A:\  
• COPY  C:\WINDOWS\COMMAND\FDISK.EXE  A:\  
• COPY  C:\WINDOWS\COMMAND\XCOPY.EXE  A:\  
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A pack of toolkits for the administrator is essential, you can download parts for 
your pack from this link if you like: 

 
http://www.svrops.com/svrops/default.htm 

 

Managing Disk Partitions Over the Network with Ghost 
Corporate Edition 

System administrators often need to deploy images to multiple machines, or they want to make and 
send images (including system images) to machines over a network. Daniel Dern explains the process 
using Symantec Ghost Corporate Edition as a solution.  

If you're a system administrator, you may have to support dozens, hundreds, or even thousands of Windows users 
in your company. This chore probably starts with initializing new systems with a standard core set of applications.  
 
It continues with performing software and database updates/upgrades, migrating users to new machines, scrubbing 
and reinitializing loaner laptops, and restoring machines with fresh software. You could do all this work on foot, 
hand-carrying CDs, with remote users either carrying or shipping their machines—or you could use a program like  
Symantec's Ghost Corporate Edition, which lets you load and retrieve full system images over the network, and 
load images to many systems in one operation. 
 
Partition imaging is the process of deploying, saving, and restoring the full contents (also known as the image or 
image dump) of the partitions on the hard drive of a desktop or notebook computer. For many organizations, this 
process is an ongoing system administration challenge. Partition imaging includes a variety of tasks: 

• Saving a system "as received" (for example, from vendor, VAR, or integrator), for later restoring, or 
"cloning" to one or multiple machines 

• Loading the operating system and core applications (together known as the "corporate image") to a new 
system 

• Upgrading the operating system and/or applications 
• Migrating a user's data and personal settings to a new machine 
• Providing a clean system—for example, for a notebook loaner or when reissuing a used machine to a 

new user 
• System/data backup 
• Problem resolution—for example, recovery of files or even full system restore 

 
A variety of products are available to assist the system administrator in partition imaging. These are some of the 
most popular: 

• Acronis True Image 
• PowerQuest's Drive Image 
• Symantec Ghost 
• V Communications' Image Commander and Copy Commander, both included in VCOM's DriveWorks 
• Dantz Retrospect (though it's better known as a backup utility) 

 
Of these products, only one—Symantec Ghost Corporate Edition 7.5—offers the capability of making and 
restoring images (including the operating system partition) and deploying those images to a group of machines 
from a central administrative console. According to Thom Bailey, group product manager with the Ghost team,  
Ghost Corporate Edition 7.5 "[...]represents a large paradigm shift from the consumer edition, which was used for 
up to a dozen or so users, over a mapped network drive if need be." 

NOTE 

Symantec may not be alone in this area for long: According to my conversations with them, Acronis and other 
vendors are working on "central console" partition content-administration tools. Dantz Retrospect can also be used 
over the network. 
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"Remote Boot" and Remote Control 
To create or restore images, Ghost needs to reboot the user's computer. Individual users typically do this from a 
bootable floppy disk, CD, or DVD containing DOS, network, and/or peripheral drivers, and possibly the image to 
be restored. In more recent versions, such as Ghost 2003, Windows can tell Ghost to generate a virtual partition, 
which consists of the same basic information that would be put onto a Ghost boot floppy, but put directly into the 
Master Boot Record. The machine then reboots into the virtual partition. (The virtual partition and its contents go 
away when the computer is powered down or rebooted.) 

NOTE 

For licensing reasons, Symantec includes PC-DOS with Ghost for use in creating the bootable disks and the virtual 
partition from within Ghost—increasingly important, as newer versions of Windows may not create MS-DOS 
bootable media. 
 
In addition to Ghost proper, Symantec Ghost Corporate Edition (hereafter just called "Ghost Corporate") includes 
the Ghost console for browsing and locating computers on the network, and the Ghost client. The client can be 
included in a Ghost system image installed on the system; alternatively, the client can be installed on the remote 
machine after the Ghost console has found the target PC on the network. 
 
For example, working from the Ghost console and using basic Windows network browsing, a system administrator 
could locate all the Windows machines on a network, and send and install the Win32 Ghost client on those 
machines. Once installed, the Ghost client can create a Ghost virtual partition that includes TCP/IP drivers, 
allowing the system to be controlled from the Ghost console—thereby eliminating the need to visit the remote PC 
with a boot floppy or deploying a physical boot partition. 
 
"The Windows-based client is not available to the user on the System Tray or to Start, Programs," notes Bailey. 
"It's a tiny client-side technology that only speaks with the Ghost console. And we have a public and private key 
infrastructure so that only the right administrator can speak to it." 
 
After the Ghost client is installed on these systems, the administrator can organize the systems—for example, by 
department or by subnet—and establish tasks such as the following: 

• Take Ghost images of each machine 
• Do incremental backups 
• Save each machine's "PC Personality"—user settings, look-and-feel of a given machine, contents of My 

Documents, and so on 
 
The GhostCast Server lets the system administrator deploy images to one or more machines by unicast (to one 
machine), subnet targeted broadcast (selectively based on subnet grouping), or multicast (to many computers). A 
new option allows users to initiate Ghost restores and other tasks from the local machine, accessing remotely 
stored images. 
 
According to Bailey, Ghost Corporate also supports other imaging methods: 

• Using the preboot execution environment (PXE) to let PXE-compliant PCs (which should be nearly all 
PCs) boot directly to a network and look for a PXE server. This technique still requires a person at each 
machine, however. 

• Using Ghost32, a 32-bit Ghost client, with the Windows Preinstallation Environment (also known as 
Windows PE or WinPE). This method includes more drivers and is a true 32-bit environment, versus 
booting into a version of DOS. 

"Ghost will always have DOS or a DOS replacement, which is very small, for bare-metal restore (bringing a PC 
back that's failed, where there's no Windows available to use Ghost software). You need DOS to get started," 
Bailey says. "But Windows PXE is gaining a great  
 

Using Ghost Successfully 
Jason McKinney, a system administrator at the Washington State Liquor Control Board, uses Ghost. According to 
McKinney, the Board currently has about 1,100 computers located in stores across the state, as either "smart" cash 
registers or backroom PCs for managers to handle management, payroll, email, Web access, and other tasks. Data 
generally doesn't reside on these machines, but is pushed upstream to GHQ (headquarters), using either dial-up or 
frame-relay connections. 
 
"We're using Ghost the way a lot of people are using it," says McKinney. "We send new desktop machines out to 
replace old ones. We buy yearly or every other year, roughly, replacing a third of the machines each two years, or 
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whatever. We purchase and prepare machines here at GHQ, and then send them out. We use Ghost to load a 
standard image." To do this, McKinney reports, "I set up a process in the Liquor Board so it can be done at the 
desktop or at the user's station, from any network station with proper user authentication. I have to 'visit' each new 
machine long enough to plug it into the network and log onto it in the network boot environment, in order to 
confirm I'm allowed to zero the disk out, but from there we can load it using the Ghost console and client. We may 
also use Ghost Corporate's multicast feature...we've done it with [up to] twenty systems at a time. We use 
snapshots from a fully prepared machine, e.g., a lab machine for our training lab, and then re-image them back." 
 
For the most part, McKinney uses Ghost simply to deploy the initial image. "Our users aren't installing things; our 
goal is for them to not install anything. Once they're deployed, the only time you use Ghost again is if something 
goes bad, and you need to re-image." He also uses Ghost to take an image of a server for archival purposes. "For 
example, before I decommission a server, I Ghost an image, and put that image on a tape—and hopefully never 
need it again." 
 
Rather than provide users with CDs containing a copy of the Ghost system image, McKinney says, "Since we have 
techs go on rounds to the stores often enough, if somebody needs a reload we tend to send out hard drives with 
images on them and swap them in. Nobody has yet undertaken the task of setting up a restore CD, which would 
require multiple CDs—the hardware currently doesn't have a DVD drive. Also, our current approach avoids 
someone in the store thinking that using those restore CDs might solve something...and [wiping] out their entire 
system." 
 

To Ghost or Not To Ghost 
Ghost may not be the most appropriate solution for backing up servers or making changes to large databases; here, 
something like Dantz Retrospect may be a better choice. 
 
For servers on Windows systems, another option is Microsoft's Automated Distribution Service (ADS), part of 
Microsoft's Distributed Services Initiative (DSI) for distributing new Windows 2000/2003 images, notes Tom 
Henderson, managing director of ExtremeLabs, Inc. 
 
Ghost users also using Roxio GoBack should be aware that Ghost currently won't capture any GoBack 
information, as it's put in a hidden area. (Windows XP rollback information will be included, since that's "in the 
system.") 
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